Back to overview
Downtime

Game Panel unavailable

Feb 26 at 10:54am CET
Affected services
Game Panel

Resolved
Feb 26 at 11:36am CET

The panel is now available.
Sorry for the inconvinience.

Created
Feb 26 at 10:54am CET

Game Panel is currently unavailable due the update to newer version.
It will take approx. 30 minutes.